登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

pcwanli的博客

nx

 
 
 

日志

 
 

eregi()函数在php 5.30不被支持  

2011-02-18 17:05:38|  分类: php |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
登陆后台模板选择的地方出现以下报错信息

Deprecated:  Function eregi() is deprecated in /var/www/ecshop/admin/template.php on line 843


产生错误的原因是:
eregi()函数在php 5.30不被支持


修正方法:
admin/template.php  843行的
  1. if (eregi("^(style|style_)(.*)*", $file))
复制代码
修改为
  1. if (preg_match("/^(style|style_)(.*)*/i", $file))
复制代码
  评论这张
 
阅读(820)| 评论(0)

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018